Remarque
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de vous connecter ou de modifier des répertoires.
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de modifier des répertoires.
Cet article fournit des étapes générales pour résoudre les problèmes que vous pouvez rencontrer lorsque vous appliquez une mise à jour cumulative (CU) ou Service Pack (SP) à votre instance Microsoft SQL Server. Il fournit également des informations sur la résolution des messages d’erreur ou des conditions suivants :
-
Wait on Moteur de base de données recovery handle failedmessage et erreurs 912 et 3417 lorsque vous exécutez des scripts de mise à niveau. - Erreurs d’installation qui se produisent en raison de fichiers MSI ou MSP manquants (mise à jour) dans le cache Windows Installer.
-
The Moteur de base de données system data directory in the registry is not validouthe User Log directory in the registry is not validmessages. -
Network path was not foundet d’autres messages d’erreur reçus si le service de Registre distant ou les partages d’administrateur sont désactivés sur une instance de cluster de basculement Always On (FCI) ou des groupes de disponibilité Always On.
Informations sur l’installation des mises à jour cumulatives et des Service Packs
Cette section fournit des informations sur les installations cu et SP.
Pour Microsoft SQL Server 2016 et versions antérieures :
- Avant d’installer une CU, vérifiez que votre instance SQL Server est au niveau de Service Pack approprié pour cette CU. Par exemple, vous ne pouvez pas appliquer CU17 pour SQL 2016 SP2 avant d’appliquer SP2 pour l’instance SQL Server 2016.
- Vous pouvez toujours appliquer la dernière CU pour une base de référence SP donnée sans avoir à appliquer les CU précédentes pour ce Service Pack. Par exemple, pour appliquer CU17 pour l’instance SQL Server 2016 SP2, vous pouvez ignorer l’application des mises à jour antérieures, à savoir CU14, CU15 et CU16, si elles ne sont pas installées, et appliquer CU17 directement.
Pour Microsoft SQL Server 2017 et versions ultérieures, vous pouvez toujours appliquer la dernière CU disponible. (Aucun service pack n’existe pour SQL Server 2017 et versions ultérieures.)
Avant d’appliquer un CU ou un SP, vérifiez que l’instance que vous mettez à jour est correctement installée. Les fichiers de programme et les fichiers de données SQL Server ne peuvent pas être installés sur :
- Lecteur de disque amovible.
- Système de fichiers qui utilise la compression.
- Répertoire dans lequel se trouvent les fichiers système.
- Lecteurs partagés sur une instance de cluster de basculement.
Si vous ajoutez une fonctionnalité de moteur de base de données après l’application d’un CU ou d’un SP à une instance, vous devez mettre à jour la nouvelle fonctionnalité au même niveau que l’instance du programme avant d’appliquer de nouveaux CU ou SP.
Méthodologie générale de résolution des problèmes
Isolez l’erreur en procédant comme suit :
- Sélectionnez Détails dans l’écran Échec du processus d’installation.
- Dans le dossier %programfiles%\Microsoft SQL Server\nnn\Setup Bootstrap\Log, vérifiez Summary.txt sous la section Fonctionnalités du produit détectées pour déterminer si l’une des fonctionnalités répertoriées signale un échec. Si c’est le cas, vous pouvez vous concentrer sur la résolution des problèmes qui affectent cette fonctionnalité.
- Accédez au sous-dossier nommé yyyyMMdd_HHmmss (par exemple 20220618_174947) qui correspond à l’heure de l’échec signalée sur laquelle vous vous concentrez. L’objectif est d’examiner les fichiers spécifiques aux fonctionnalités, les fichiers ERRORLOG et le fichier Details.txt, si nécessaire.
- Accédez au sous-dossier \MSSQLSERVER et recherchez les fichiers journaux spécifiques à la fonctionnalité qui a échoué. Par exemple, sql_engine_core_inst_Cpu64_1.log. Pour les échecs de script de mise à niveau, vérifiez les fichiers SQLServer_ERRORLOG_date_time.txt correspondant à l’heure de l’échec de la mise à niveau.
- Ouvrez le fichier journal Details.txt , puis recherchez le mot clé « Échec ». Toutes les défaillances ne sont pas considérées comme critiques.
Pour plus d’informations, consultez Afficher et lire les fichiers journaux d’installation de SQL Server.
Dans les sections suivantes, recherchez un scénario qui correspond à votre situation, puis suivez les étapes de résolution des problèmes associées. S’il n’existe aucun scénario correspondant, recherchez d’autres indices dans les fichiers journaux.
Erreurs 912 et 3417 et « L’attente du handle de récupération du Moteur de base de données a échoué »
Les scripts de mise à niveau T-SQL sont fournis avec chaque mise à jour cumulative SQL Server. Ils sont exécutés une fois les fichiers binaires SQL Server remplacés par les dernières versions. Si ces scripts T-SQL ne s’exécutent pas pour une raison quelconque, le programme d’installation signale une erreur « Wait on Moteur de base de données recovery handle failed ». Le programme d’installation enregistre les erreurs 912 et 3417 dans le dernier journal des erreurs SQL Server. Les erreurs 912 et 3417 sont associées aux échecs de mise à niveau de script de base de données et à l’échec de la récupération de la master base de données, respectivement. Les messages qui précèdent l’erreur 912 fournissent généralement des informations sur la cause racine de l’échec qui s’est produit lors de l’exécution des scripts de mise à niveau.
Il pourrait y avoir une variété d’erreurs soulevées avec 912 et 3417. Pour plus d’informations sur un résumé des scénarios courants et des solutions associées, consultez Résoudre les échecs de script de mise à niveau lors de l’application d’une mise à jour.
Erreurs d’installation provoquées par des fichiers d’installation manquants dans le cache Windows
Les applications telles que SQL Server qui utilisent la technologie Windows Installer pour le processus d’installation stockent les fichiers critiques dans le cache Windows Installer. L’emplacement du cache du programme d’installation par défaut est C :\Windows\Installer. Ces fichiers sont nécessaires pour désinstaller et mettre à jour des applications. Ils sont uniques à cet ordinateur. Les mises à jour apportées aux applications qui dépendent de ces fichiers ne fonctionneront pas si ces fichiers sont supprimés accidentellement ou compromis. Pour résoudre cette condition, utilisez l’une des méthodes suivantes décrites dans Restaurer les fichiers de cache Windows Installer manquants :
- Réparez l’installation de SQL Server.
- Utilisez l’outil FixMissingMSI.
- Utilisez le script FindSQLInstalls.vbs.
- Restaurez manuellement les fichiers.
- Restaurez des fichiers à partir des sauvegardes de l’état du système.
- Passez en revue et implémentez les procédures décrites dans Restaurer les fichiers de cache Windows Installer manquants.
Le programme d’installation échoue en raison d’un emplacement de données ou de journal incorrect dans le Registre
Lorsque vous installez un CU ou un Service Pack, si les dossiers de données et de journaux par défaut ne sont pas valides, vous pouvez recevoir des erreurs qui ressemblent aux messages suivants :
« Le répertoire des données utilisateur dans le Registre n’est pas valide. Vérifiez que la clé DefaultData sous la ruche de l’instance pointe vers un répertoire valide. »
« Le répertoire du journal des utilisateurs dans le Registre n’est pas valide. Vérifiez que la clé DefaultLog sous la ruche de l’instance pointe vers un répertoire valide. »
Erreur lors de l’installation des fonctionnalités d’instance des services Moteur de base de données SQL Server. Le répertoire de données système Moteur de base de données dans le Registre n’est pas valide. »
Pour résoudre ce problème, effectuez les étapes suivantes :
- Connectez-vous à l’instance SQL Server à l’aide de SQL Server Management Studio (SSMS).
- Cliquez avec le bouton droit sur l’instance SQL Server dans l’> et sélectionnez PropriétésParamètres de la base de données.
- Sous Emplacements par défaut de la base de données, vérifiez que les dossiers des données et des journaux sont corrects.
- Dans le Gestionnaire de configuration SQL Server, sélectionnez SQL Server Services, double-cliquez sur le service SQL Server affecté, sélectionnez l’onglet Avancé, puis vérifiez que la valeur de Data Path est correcte. La valeur est grisée et ne peut pas être modifiée. Toutefois, si vous souhaitez le corriger, suivez la méthode 2 dans l’erreur indiquant que le répertoire de données ou de journal du Registre n’est pas valide lors de l’installation de la mise à jour cumulative SQL Server ou d’un Service Pack pour modifier l’entrée de registre SQLDataRoot.
- Réessayez l’installation du CU ou du SP.
Nœuds de clustering de basculement Windows Server (WSFC) mal configurés
Pour assurer le bon fonctionnement et une maintenance optimale d’une instance de cluster de basculement SQL Server, suivez les meilleures pratiques décrites dans Avant d’installer le clustering de basculement et administration et maintenance de l’instance de cluster de basculement. Si vous rencontrez des erreurs lorsque vous appliquez un CU ou un SP, vérifiez les conditions suivantes :
- Vérifiez que le service Remote Registry est actif et s’exécute sur tous les nœuds du cluster WSFC.
- Si le compte de service pour SQL Server n’est pas administrateur dans votre cluster Windows, assurez-vous que les partages d’administration (C$ et ainsi de suite) sont activés sur tous les nœuds. Pour plus d’informations, consultez Vue d’ensemble des problèmes qui peuvent se produire lorsque des partages administratifs sont manquants. Si ces partages ne sont pas configurés correctement, vous remarquerez peut-être un ou plusieurs des symptômes suivants lorsque vous essayez d’installer une CU ou un SP :
- La mise à jour prend beaucoup de temps pour s’exécuter ou ne répond pas. Les journaux d’installation ne révèlent aucune progression.
- Les journaux d’installation contiennent des messages tels que les suivants :
The network path was not found.System.UnauthorizedAccessException: Attempted to perform an unauthorized operation.
Informations supplémentaires
- Pour obtenir la liste complète des mises à jour actuellement disponibles pour votre version de SQL Server et les emplacements de téléchargement, consultez Déterminer la version, l’édition et le niveau de mise à jour - SQL Server.
- Pour plus d’informations sur la prise en charge et les calendriers de maintenance de votre version de SQL Server, consultez la page Cycle de vie des produits Microsoft.
- Pour plus d’informations sur les modèles de maintenance pour différentes versions de SQL Server, consultez Le modèle de maintenance incrémentielle pour les mises à jour SQL Server et le modèle de maintenance moderne pour SQL 2017 et versions ultérieures.
- Pour obtenir des informations générales sur la mise à jour de SQL Server, consultez Installer les mises à jour de maintenance de SQL Server.
- Pour plus d’informations sur les mises à jour de sécurité pour SQL Server et d’autres produits, consultez Guide des mises à jour de sécurité.
- Pour plus d’informations sur la terminologie standard associée aux mises à jour Microsoft, consultez Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft.
- Pour résoudre les problèmes d’installation qui peuvent se produire dans des environnements hautement sécurisés, consultez l’installation de SQL Server échoue si le compte d’installation ne dispose pas de certains droits utilisateur.